[ Table Of Contents ][ Answer Guy Current Index ] greetings   Meet the Gang   1   2   3   4   5   6   7   8   9 [ Index of Past Answers ]

(?) The Answer Gang (!)

By Jim Dennis, Ben Okopnik, Dan Wilder, Breen, Chris, and... (meet the Gang) ... the Editors of Linux Gazette... and You!
Send questions (or interesting answers) to The Answer Gang for possible publication (but read the guidelines first)

(?) Can't See Boot Messages Even Though RedHat 7.2 Boots OK

From Bill Rust

Answered By Thomas Adam, Heather Stern


I'm at a bit of a loss. When I install RedHat Linux 7.2, I get the Grub menu, and after I select Linux, the screen goes blank.

(!) [Thomas] This happens on my "oh so wonderful" laptop occasionally. I know this may seem strange, but does the blank screen go, if you press any key on your keyboard????

(?) I can see the hard disk accessing, and after a couple of minutes X starts, and life is good.

(!) [Thomas] That really depends as to whether or not you like using X-Window (X11). Personally, I am much more comfortable at the console. :-)

(?) When I check my dmesg and /var/log messages file, I see no error messages on the boot. I also noticed that when I boot for the install and to boot in rescue mode, I not only get messages, I get the picture of Tux in the upper left corner of the display.

(!) [Thomas] BINGO!! The fact that Tux appears in the upper left hand corner of your screen immediately suggests that you are using Framebuffers for your display. What this does, is it forces the console to display at a certain resolution, such as 800x600. It is particularly suited to laptop users. But why you should have FB when loading the "rescue" mode is strange......

(?) I've searched high and low in Google (web and groups), and your archives and can't seem to find an answer. Any help would be appreciated.


Athlon 1.33GHz (clocked at 1.33, at least for now)
ATA 100 UDMA Promise (motherboard) IDE
IBM 7200 RMP 40GB HD
Geforce 2 TI/AGP w/64DDR
SB Live value
12/10/32A Plextor CDRW

I am dual booting with Win98SE (for games)

Things I've tried:

(!) [Thomas] Since you have already changed your lilo.conf file to:
then perhaps we can rule out the this cannot be a FB (FrameBuffer) problem???
(!) [Heather] Probably the modelines it is calculating for "text mode" are not quite in your monitor's range. The nice thing is since X works you can use xvidtune or even capture the console messages to find out which modeline it is using, and there is some utility out there which can convert X modelines to framebuffer values. Unfortunately I don't recall what it is, But fbset would be the tool you'd use with the resulting knowledge of a good horizontal sync, vertical refresh, and dotclocks rate.
Telling LILO to use vga=ask is only half of the troubleshooting -- you also need to know what to answer, because the nice graphical-text modes will not be listed there. Here's the table from the Linux sources /Documentation/fb/vesafb.txt file:
    | 640x480  800x600  1024x768 1280x1024
256 |  0x301    0x303    0x305    0x307
32k |  0x310    0x313    0x316    0x319
64k |  0x311    0x314    0x317    0x31A
16M |  0x312    0x315    0x318    0x31B
But, oh no, it warns that LILO cannot handle hexadecimal, you have to change them to decimal, 771 for instance.
Try any of these until one of them makes your system happy, then tell LILO to use it all the time instead of asking any more.
(!) [Thomas] (You did remember to run:
after you updated the lilo.conf file :-)??? )
Other than trying my suggestions already mentioned, I don't know what else I can do.
Perhaps you could send us a copy of the command:
dmesg &> ~/dmesg.txt
Kind Regards,
Thomas Adam
P.S. I like the structure of this e-mail. It clearly states the problem, and what the querent has tried to do in order to solve it -- well done!!!
Ben's article is working....... :-)

(?) Thanks for the quick response!

(!) [Thomas] :-) All part of the service!

(?) OK, I tried the keyboard thing after the screen went blank; no such luck, same behavior

(!) [Thomas] Oh well. It was always a "shot in the dark" (do excuse the pun!)

(?) I tried setting my initdefault to 3 instead of 5 in the /etc/inittab file. It still went blank immediately after the grub menu goes away,

(!) [Heather] Oh dear, I don't know how to tell it to use other VGA modes in grub. With any luck it's just an extra option that the kernel itself acceopts,

(?) but interestingly enough, I never got a prompt after what I can only presume was the end of the boot process.

(!) [Thomas] Thats because you don't usually get "a prompt" (well, you do, but....). By prompt, I assume that you mean a login prompt?? What happens when you change your defaulr inittab to 5 is that your login prompt does appear in text, but is immediately switched to tty7 where a graphical one takes its place.
I know this may seem strange, but you should "listen" to your monitor as it boots up into init 5. If you hear a series of clicks then it is booting into a graphical display ok.

(?) Since I'm working blind here, I can assume one of two things

(!) [Thomas] ...

(?) 1) my console is not functioning

(!) [Thomas] No....its functioning ok. You said it yourself, that you can get a prompt if you do a CTRL-ALT-FX key sequence.

(?) or 2) the system is hung. I suspect the latter, because when I try to bring up another terminal (CTRL-ALT F2, F3, etc), I still get nothing - by the way, CTRL-ALT F2 does work when I boot level 5. I used the CD in rescue mode to reset my inittab back to 5, and here I am up and running again (still have the blank screen tho).

(!) [Thomas] You know, I have had this situation before. In some displays, there is a problem of getting the text to display itself when at the console.
What you could try, is the following:
[ ** I do not know how the init structure (i.e.
location of files is
organised under RedHat. But, if it is anything like
SuSE, then the init
files should be in "/etc/init.d" -- as per the LSB
standard ** ]
You should have on your system, a file called:
into this file, add the following command:
setfont &
That might, un-blank your screen, it works on my laptop, and might just solve your problem.

(?) I forgot to mention that I tried the 'nofb' argument after reading the bootprompt HOWTO. I'm not ready to rule out the frame buffer, however.

Maybe the answer would be to try to get it to work.

Any pointers as to where I could find a HOWTO??

(!) [Thomas] Aye....you could have a peek at the following website:

(?) With regards to the lilo question. Yes, I did run lilo after the changes. The reason I am referring to the Grub screen now is because I eventually had a boot problem.

(!) [Thomas] What kind of boot problem?? Lilo has been the de-facto boot loader for Linux, for years, and is adept and handling most things in my opinion. And it now offers nice colourful menus, which it did not before.

(?) Since, I couldn't see the screen, I couldn't see an error message. I was then able to use the rescue mode on the CDROM, but I couldn't find anything in the /var/log/messages file. I also did an 'ls -lrt' in the log directory to see if there were any newly updated files from the same day, but didn't see anything. I eventually gave up and reinstalled Linux.

(!) [Thomas] Hum....this is a very interesting problem Bill.

(?) I have attached the dmesg text. Thanks for the tips; I hope we can get this mystery solved!

(!) [Thomas] I'm trying :-)
I looked over your dmesg output...nothing out of the ordinary there.
Keep at it. I hope I have been of some help. Do let me know if my suggestion succumb or not.
Kind Regards,
Thomas Adam
(!) [Heather] Unfortunately that dmesg output was lost from the threads visible to me. However, I post this note here, with my additional comments about selecting framebuffer modes, and in the hopes that someone amongst our readers may be able to shed some light on his monitor's darkness.

This page edited and maintained by the Editors of Linux Gazette Copyright © 2002
Published in issue 77 of Linux Gazette April 2002
HTML script maintained by Heather Stern of Starshine Technical Services, http://www.starshine.org/

[ Table Of Contents ][ Answer Guy Current Index ] greetings   Meet the Gang   1   2   3   4   5   6   7   8   9 [ Index of Past Answers ]