"The Linux Gazette...making Linux just a little more fun!"

(?) The Answer Guy (!)

By James T. Dennis, tag@lists.linuxgazette.net
Starshine Technical Services, http://www.starshine.org/

(?) Another "No Login" Problem

From s.alexiou on Tue, 26 Jan 1999

(?) I have RH 5.0 (2.0.32). Using their graphic tool, I created two /home accounts, me and guest, assigned UID and GID's and set passwords. The problem is, I can only log in as root. I looked for .nologin files, there seem to be none. I am attaching my /etc/fstab files. Thus, at the linux prompt If I try to login as any of these two users, I am denied entry(back to the prompt). This is not an issue of case sensitive.

Any ideas of what I am doing wrong? Sincerely, S.Alexiou

(!) I have NO idea. I've gotten a rash of different reports of this sort. All involve Red Hat usually right after new installations --- no login from console, no login over telnet, no login as root, no login as anyone other than root.
Unfortunately all of these cases, so far, are being reported to me incompletely. Only sparse details ahve been provided (as above). I've mailed off troubleshooting suggestions and recieved no followup to explain them.
So, I don't get it.
You said you used their graphical tool to create two new accounts. One was named "guest" and the other was some sort of user name for yourself. You also said you set the passwords for these two accounts.
Let's try this: edit your passwd file. I personally prefer to use vipw for that --- but Red Hat 5.0 had a broken 'vipw' command (immediate segfault) and my fresh installation of 5.2 also has a broken 'vipw' command (needed to add a symlink from /bin/vi to /usr/bin/vi --- GRRR!). So, just use your favorite editor and keep a rescue floppy handy in case you reboot the system with a corrupt /etc/passwd file.
Make sure that the entries you tried to create made it into the passwd file. Send me a copy of it if you still can't get it to work. Try setting the account passwords to something simple like just "x" --- and use the /bin/passwd command, not any sort of curses or GUI front end. Consider removing 'linuxconf' (for troubleshooting).
If you're using shadow passwords try running pwunconv and if you're not, try running pwconv (to convert your passwd file to or from shadow format).
Please, let me know if you figure out what's doing it.

Copyright © 1999, James T. Dennis
Published in The Linux Gazette Issue 37 February 1999

[ Answer Guy Index ] 1 2 3 4 5 6 7 8 9 10
11 12 14 15 16 17 18 19 21 22
23 28 29 30 31 32 33 34 37 38
39 41 42 43 44 45 46 47 48 49

[ Table Of Contents ] [ Front Page ] [ Previous Section ] [ Next Section ]