...making Linux just a little more fun!

next -->


This month's answers created by:

[ Amit Saha, Ben Okopnik, Brian Bilbrey, Kapil Hari Paranjape, Karl-Heinz Herrmann, Neil Youngman, Ramon van Alteren, Rick Moen, Mike Orr (Sluggo), Thomas Adam ]
...and you, our readers!

Still Searching

install from hard-disk

Darshak [darshak at elitecore.com]
Fri, 05 Jan 2007 15:25:20 +0530

HI, I have no CDROM/Floppy. My red-hat linux ISO [ 2.6]are there into HDD.Harddisk also contains red-hat linux-kernel2.4 I want to install that 2.6 kernel into hard-disk. Can I do this? In fedora -core while installation we can use From hard-disk.Can i make my USB pendrive such that it also boots and asks the location of hard-disk.And then continues installation.



wireless card motorola 80211g dont work on ubuntu or knoppix im told it should

jerry [needadamnjob2003 at yahoo.com]
Thu, 4 Jan 2007 07:47:28 -0800 (PST)

the boards ive seen say it does also im kinda new an defanitly no teckie or coder can ya help i dont use this email any more so pls answer this an send it to gmail its pacman269@gmail.com thanks o if you need to no im tryn to use christian ubuntu and knoppix 5 i guess its the new one out the laptop is a A22m stinkpad ibm bois says 800m an 384mof mem but everest says 647m an 384m for mem so i dont no what one is rite any way you look at it its old........ thanks pac.

Our Mailbag

pen drive with linux

[j.bakshi at icmail.net]
Mon, 15 Jan 2007 21:53:24 -0800

First of all thanks to Ramon van Alteren for make me familiar with some more linux router features.

now one more question is flying around my linux head :-) I have seen in suse that after plugin the usb pen drive ; konqueror fires up automatically opening the drive. I like to know the inner secret so that I can implement this in my debian linux box.

thanks, Happy Linuxing

[ Thread continues here (3 messages/2.66kB) ]

Followup: Linux on AMD sempron (LG134)

Predrag Ivanovic [predivan at ptt.yu]
Mon, 1 Jan 2007 15:52:16 +0100

On Sun, 17 Dec 2006 11:29:38 +0530 Amit Saha wrote:

> Hi all!

> I recently installed FC5 and FC6 on a newly acquired AMD 2800+ Sempron
> processor(64-bit). There are a few things i would like to get cleared
> 1. While the packages were being copied, I noticed the i386 extension
> packages being copied. Isnt i386 supposed to mean intel 80386?


"IA-32, sometimes generically called x86-32, is the instruction set architecture of Intel's most successful microprocessors. This is a 32-bit extension of the original Intel x86 processor architecture. The term means Intel Architecture, 32-bit, distinguishing it from the preceding 16-bit x86 processors, and the later 64-bit architecture IA-64, also known as the Itanium architecture. IA-32 has had such longevity partially because of full backwards compatibility. The non-proprietary, generic name for this 32-bit architecture is x86-32."

> 2. The FC5 and FC6 that i installed on my 64-bit AMD was also installed on
> my 32-bit celeron. That means i am using 32bit OS on my 64-bit machine
> right? Will i gain performance by using FC5 for 64-bit?

Not FC5/FC6, but should give you some idea: "Ubuntu i386 & x86_64 Compared"


Personally, I would take dual/quad core processor over 64-bit one any day :)

> Which is the best distro to use on AMD sempron 2800+ ?

Define 'best'.


 The choices you make, whether good or bad,  make you
  more of who you are and less of who you could be.

RealPlayer not playing well with others

Mike Orr [sluggoster at gmail.com]
Wed, 27 Dec 2006 22:22:35 -0800

I just set up a Kubuntu system with RealPlayer, and it refuses to squack simultaneously with another noisemaker. It sulks silently if kaffeine/kscd/kmix is open, and silences them when it's playing. It's opening /dev/dsp directly rather than going through the sound system.

The setup wizard says, "Alsa and esound drivers are not included in this build. The OSS device used for playback can be set using the AUDIO environment variable. eg export AUDIO=/dev/dsp2." But I've used Real on Kububtu and Gentoo before without this problem.

I looked in the dialogs for an output device setting but didn't see any. KDE's sound system is usisng the "autodetect" audio device, and KInfoCenter says, "Installed drivers: type 10 ALSA emulation. Audio devices: VIA 8237 (DUPLEX)".

gxine and kaffeine will play RealAudio files, but gxine distorts the sound in an annoying way, and kaffeine crashes so frequently I forget I'm not on Windows. (It even hung the system once with gray vertical bars on the screen. I haven't seen that on Linux for years.)

Interestingly, when KMix is open Reaplayer is silent until I close KMix and restart the audio clip a few times. But if RealPlayer is running and I open KMix from the volume control in the tray, I can adjust the volume with KMIx's PCM slider.

Mike Orr <sluggoster@gmail.com>

[ Thread continues here (2 messages/3.10kB) ]

Diagnosing SATA problems

Neil Youngman [ny at youngman.org.uk]
Mon, 22 Jan 2007 21:23:58 +0000

I've been having problems with my SATA disk for some time and I've moved back to working off my old IDE disk, while I investigate the problem. I'm assuming the problem is hardware, but I don't have any suitable hardware to swap around to prove the point. I think my next step is to buy another SATA controller and swap that, but first I thought I'd see if the gang's collective wisdom had any pointers to offer.

[ ... ]

[ Thread continues here (2 messages/10.51kB) ]

X error on Kubuntu

Mike Orr [sluggoster at gmail.com]
Sat, 6 Jan 2007 20:27:23 -0800

Here's another error I've been getting on all my Kubuntu installs:

X Error: BadDevice, invalid or uninitialized input device 171
  Major opcode:  146
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 171
  Major opcode:  146
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
This happens whenever an X application starts, and sometimes when it opens a new window. Apparently it retries a couple times and succeeds, because I found one application that just gave up and wouldn't start at all. I don't remember which one now, not one of the X apps I'm currently using

Mike Orr <sluggoster@gmail.com>

[ Thread continues here (2 messages/1.67kB) ]

how to share internet from a linux server

[j.bakshi at icmail.net]
Wed, 10 Jan 2007 03:43:52 -0800

kindly CC to me --------------------------- Dear list,

here is the actual situation which I like to share with you. I have a Suse10 box with 2 lan card. I also have a 10 port HUB. Now I like to dial my ISP with one lan card and another lan will be connected with the HUB. hence the other PCs can share the net connection from the HUB. I like to implement this. Could any one suggest any tutorial or suggest me to do this ??

thanks for your support.

[ Thread continues here (12 messages/21.04kB) ]

appache dreamweaver problem

[j.bakshi at icmail.net]
Thu, 11 Jan 2007 21:23:47 -0800

Dear list,

I am facing a really critical problem since last one weak. My server is running XAMPP for linux. Now the users are accessing the server and doing their project work using dreamweaver from win PC.

but frequently they see the message "This file has been modified outside of Dreamweaver. Do you want to reload it"

I am 100% confirm that there is no one elese who is working on a particular file. if they accept yes all their modification has been lost. Is there any problem in the Linux server or Xampp ?

has any one experienced such a problem ? please suggest. thanks.

[ Thread continues here (3 messages/5.92kB) ]

microsim/ubuntu 6.06 lts

socially teamed [sociallyteamed at yahoo.com]
Fri, 29 Dec 2006 07:30:59 -0800 (PST)

I am having a little trouble intsalling microsim on ubuntu 6.06 lts please help me i am very intersted in using your software thank you i get this type of message:

 t0k3r@t0k3r-laptop:~/Desktop$ cd version-1.0
 t0k3r@t0k3r-laptop:~/Desktop/version-1.0$ ./install
 Make microsim ...
 make: * No rule to make target
 `/usr/lib/qt-3.3/mkspecs/default/qmake.conf', needed by `Makefile'.  Stop.
 Change ownership ...
 chown: cannot access `microsim': No such file or directory
 Change permissions ...
 chmod: cannot access `microsim': No such file or directory
 t0k3r@t0k3r-laptop:~/Desktop/version-1.0$ su
 root@t0k3r-laptop:/home/t0k3r/Desktop/version-1.0# ./install
 Make microsim ...
 make: * No rule to make target
 `/usr/lib/qt-3.3/mkspecs/default/qmake.conf', needed by `Makefile'.  Stop.
 Change ownership ...
 chown: cannot access `microsim': No such file or directory
 Change permissions ...
 chmod: cannot access `microsim': No such file or directory
 root@t0k3r-laptop:/home/t0k3r/Desktop/version-1.0# microsim
 bash: microsim: command not found
 root@t0k3r-laptop:/home/t0k3r/Desktop/version-1.0# microSim
 bash: microSim: command not found
 root@t0k3r-laptop:/home/t0k3r/Desktop/version-1.0# make install
 make: * No rule to make target
 `/usr/lib/qt-3.3/mkspecs/default/qmake.conf', needed by `Makefile'.  Stop.
 root@t0k3r-laptop:/home/t0k3r/Desktop/version-1.0# make ./install
 make: * No rule to make target
 `/usr/lib/qt-3.3/mkspecs/default/qmake.conf', needed by `Makefile'.  Stop.
 root@t0k3r-laptop:/home/t0k3r/Desktop/version-1.0# Make install
 bash: Make: command not found
 root@t0k3r-laptop:/home/t0k3r/Desktop/version-1.0# ./microsim
 bash: ./microsim: No such file or directory
 root@t0k3r-laptop:/home/t0k3r/Desktop/version-1.0# microsim.ui
 bash: microsim.ui: command not found
 root@t0k3r-laptop:/home/t0k3r/Desktop/version-1.0# ./microsim.ui
 ./microsim.ui: line 1: syntax error near unexpected token `<'
 ./microsim.ui: line 1: `<!DOCTYPE UI><UI version="3.3" stdsetdef="1">'
 root@t0k3r-laptop:/home/t0k3r/Desktop/version-1.0# ./install
 Make microsim ...
 make: * No rule to make target
 `/usr/lib/qt-3.3/mkspecs/default/qmake.conf', needed by `Makefile'.  Stop.
 Change ownership ...
 chown: cannot access `microsim': No such file or directory
 Change permissions ...
 chmod: cannot access `microsim': No such file or directory

[ Thread continues here (2 messages/5.47kB) ]

Computer crime/spam on the rise (via RISKS-LIST)

Benjamin A. Okopnik [ben at linuxgazette.net]
Sat, 30 Dec 2006 01:49:07 -0500

>From a recent Risks-Forum Digest (Monty Solomon, "Cybercrooks Deliver Trouble"):
One of the best measures of the rise in cybercrime is junk e-mail, or spam,
because much of it is relayed by computers controlled by Internet criminals,
experts said. More than 90 percent of all e-mail sent online in October was
unsolicited junk mail, according to Postini, an e-mail security firm in San
Carlos, Calif. Spam volumes monitored by Postini rose 73 percent in the past
two months as spammers began embedding their messages in images to evade
junk e-mail filters that search for particular words and phrases. In
November, Postini's spam filters, used by many large companies, blocked 22
billion junk-mail messages, up from about 12 billion in September.
Gosh, who could possibly have predicted that content-based filtering wouldn't work?





LOTS of other places as well, of course; Rick has been vocal enough about SPF here, and I strongly suspect elsewhere as well. So have many other people. It's just that now, the problem is coming to roost in a big way, and all these people are now scrambling in panic.

Perhaps - one day, after the human race grows up - we'll all have a reflex that causes us to do the obvious things that prevent problems instead of focusing all our energies on emergency management. The latter makes you look like a hero if you pull it off... but the chances of failure, with attendant chances of damage or death, are high and not very controllable. For now, we just get to watch the frenzied scrabbling for a way out, with its usual outcome of mostly-wrong answers.

("I told you so"s may be personally satisfying but don't do much to change the situation. As Honda's motorcycle safety ads say, "Stupid Hurts.")

* Ben Okopnik * Editor-in-Chief, Linux Gazette * http://LinuxGazette.NET *

how to share cd writer from linux box ?

[j.bakshi at icmail.net]
Thu, 11 Jan 2007 02:21:27 -0800

kindly cc to me ----------------------------

Dear list,

hope every one is happy with linux :-)

Ok . now I have a little bit of problem with linux. my linux server has a cd writer and a DVD writer. the server already has samba. now what can I do in my smb.conf file so that windows clients can use both the writers of the linux server ?

could any one plese suggest any thing ?

thanks and wish all happy linuxing :-)

[ Thread continues here (3 messages/3.22kB) ]

problem with 2 isp and sharing

[j.bakshi at icmail.net]
Thu, 04 Jan 2007 21:22:32 -0800

Dear list,

hope every one is well in the new year and charged to do more with linux :-)

I have a critical problem with my net setting and searching for some kind guidance.

well, I have 2 ISP and a load balancing router ( Linksys RV042). My one ISP, say ISP1 is based on ADSL technology. The modem to dialup ISP1 is smartATX MT841 and it has inbuilt dialing feature. so a connection from this smartATX MT841 direcly comes to WAN1 port the of the load balancing router.

another ISP, say ISP2. now there is a PC with 2 lan card for this isp2. one lan dialups ISP2 and another lan card from this same machine fed this connection to the WAN2 port of the load balancing router.

till now there is no problem at all and the load balancing feature is running great.

BUT the problem is with the PC which dialups the ISP2 and fed the connection to the load balancing router. it actually behaves like a modem. so the user in that machine can't share the local lan resources and we can't share the resources of that PC.

could any one kindly suggest any solution please ? thanks for the support.

[ Thread continues here (2 messages/1.48kB) ]

Camera permissions on Kubuntu

Mike Orr [sluggoster at gmail.com]
Sat, 6 Jan 2007 19:45:52 -0800

Trying to mount my camera, which works fine on Gentoo and I think on another Kubuntu computer. /etc/fstab says:

/dev/sda1        /mnt/camera    vfat
user,noauto,nodev,dmask=0000,fmask=0666,uid=1000,gid=1000    0 0
(All on one line.)

But when I mount it the permissions are:

% ls -l /mnt/camera
total 32
drwxr-xr-x 3 root root 16384 2006-01-01 00:00 dcim
drwxr-xr-x 2 root root 16384 2006-01-01 00:00 misc
% ls -l /mnt/camera/dcim/100_pana/p100054*
-rwxr-xr-x 1 root root 1625995 2007-01-06 18:44
It's recognizing the user option but ignoring the uid,gid,fmask, and dmask options.

I set the unmounted directory to mode 777 owned by myself because I remembered hearing that has some effect on the mount's permissions, but it didn't make a difference.

I tried mounting it with sudo and without, and removing the uid/gid or fmask/dmask options, but it didn't help.

Mike Orr <sluggoster@gmail.com>

[ Thread continues here (3 messages/5.92kB) ]

problem configuring 2 lan with YAST in suse 10

[j.bakshi at icmail.net]
Tue, 09 Jan 2007 20:39:23 -0800

Dear list,

I am running a PC having suse 10. I have 2 lan card here and like to configure 2 cards with different setting. I have tried to configure the cards using Yast, but the problem is ; 2 cards taking the same DNS, gateway etc from the configuration which I make latter. I think there may be some problem in yast, so I like to do it manually. could any one suggest me the file in suse 10 where I can write configuration for eth0 and eth1 and could any one kindly provide an example configuration :-)

thanks in advanced.

[ Thread continues here (3 messages/3.80kB) ]

Online office suites

Jimmy ORegan [joregan at gmail.com]
Sun, 21 Jan 2007 13:27:47 +0000

I was going back over the past few days of Slashdot, and found this: http://slashdot.org/article.pl?sid=07/01/19/216208 , a link to a review (http://www.computerworld.com/action/article.do?command=viewArticleBasic&articleId=9007884) of online office suites.

The interesting part is that Slashdot also mention Docvert[1] (http://holloway.co.nz/docvert/index.html), an open source, web based document converter - not an office suite, but at least the "host my own" crowd have an option to view word processor documents (if they're willing to run public-facing software that's based on OpenOffice or Abiword...)

It's interesting that 3 of the 4 support importing and exporting OpenOffice files (although ajaxPresents from Ajax13 gives nothing but errors when you try to export openoffice, though their "own" .appt format is openoffice!).

[1] Albeit in a separate article: http://it.slashdot.org/article.pl?sid=07/01/18/1422243

Please do my homework!

dhaval jadhav [dhaval_hi2003 at yahoo.co.in]
Mon, 22 Jan 2007 06:35:01 +0000 (GMT)

[[[ This was originally entitled something really descriptive like "help!" I have retitled it with a more informative subject. (This was also presented in html format rather than text, and responses top-posted. I have corrected those errors in judgment as well.) - Kat ]]]

Hello sir. I am projected to develpe a browser/programme to see files attributes (not the file contentes) of linux(ext2/ext3) from wondows operating sys. I dont know from where should i start.please help me.

[ Thread continues here (6 messages/6.21kB) ]

Window Manager in FC5

Ramanathan Muthaiah [rus.cahimb at gmail.com]
Tue, 2 Jan 2007 23:44:31 +0530

New year greetings to all :-))

This is no new year resolution to switch from current window manager but wanted to try my hands on coule of them for my home system.

Couple of them are : iceWM, fluxbox.

But, am finding hard to find the right doc / Google search result to configure these WMs for FC5.

Can somebody help me here ?


[ Thread continues here (9 messages/9.92kB) ]

Followup: opening VA FullON 2230 (LG134)

Rick Moen [rick at linuxmafia.com]
Tue, 2 Jan 2007 00:38:53 -0800

(This is a response to your request for help, opening VA FullON 2230 just printed in Linux Gazette's issue #134.)

The article you read is correct, that it's necessary to remove the CD-ROM / floppy assembly before getting to the HDs. Here's how:

Unscrew the two Philips screws on either side of the floppy drive. Now, remove the top cover that is atop the rear 3/4 of the chassis's top surface, so that you can reach the back of the CD drive. Reaching inside the chassis, push the CD drive towards the front. This will dislodge the six-inch-wide faceplate that houses the CD and floppy drives, allowing it to slide forward.

A flange on that faceplate projecting sideways towards the hard drives is the main obstacle to removing the twelve-inch faceplate in front of the hard drives, which you now should be able to likewise dislodge forwards. That faceplate contains two very noisy, small fans: FYI, I've replaced those fans on my unit with quiet aftermarket fans, each with a slide switch letting you select one of three speeds, making my house a great deal quieter.

Once you have the twelve-inch faceplate removed, you can reach in from the front to the four drive bays, a vertical pair on the left and a similar vertical pair next to that. Each bay can accomodate a drive sled that is fastened from the front with a Philips screw in the upper left. Once you've removed the screw, the sled and attached drive should slide forwards. (You'll want to detach any cables from the drive, first.)

Speaking for the former staff of VA Linux Systems, I hope you get many long years of enjoyment from your model 2230.

Best Regards, Rick Moen

UML and vmware

J.Bakshi [j.bakshi at icmail.net]
Fri, 1 Dec 2006 22:54:42 +0530

Hi list,

Hope everyone is well here :-) I am little bit confused and seeking your guidance. I like to run a virtual machine for experiment with different S/W. Both UML and vmware are there. I like the S/W which gives less overhead to the CPU. occupies less Ram. Provides faster speed and performance. In this scenario which will be better ? could any one suggest ?

PS: Assume that both the virtual machines running with exactly same number of applications.

Please CC to me.


[ Thread continues here (7 messages/8.44kB) ]

Problem in Client when spawning multiple connections on socket

Amit Saha [amitsaha.in at gmail.com]
Wed, 17 Jan 2007 22:02:59 -0800

Hi list! i need your advice. The situation is like this

We have a situation where we have a DEC Alpha Server with a Concurrent Server which spawns a child to every process that we connect to. On a Linux box on the same network, we have built a client which connects to the server ,we see the connection and every things is good. At this time we try to invoke another instance of the this client, at this point it kills the first connection and the second one connects. We are passing the Internet address of the server to connect.

If we have the client on the same server we can spawn multiple instances and every instance connects, in this case though the address or the local host.

Any pointers as to how we can have multiple client using the same socket.

Amit Kumar Saha
GSM :+91 9903140286

[ Thread continues here (4 messages/5.29kB) ]

Talkback: Discuss this article with The Answer Gang

Copyright © 2007, . Released under the Open Publication License unless otherwise noted in the body of the article. Linux Gazette is not produced, sponsored, or endorsed by its prior host, SSC, Inc.

Published in Issue 135 of Linux Gazette, February 2007

next -->