[ Table of Contents ] [ Front Page ] [ Linux Gazette FAQ ] [ Next ]

"Linux Gazette...making Linux just a little more fun!"

 The Mailbag!

Write the Gazette at gazette@ssc.com


Help Wanted -- Article Ideas

Answers to these questions should be sent directly to the e-mail address of the inquirer with or without a copy to gazette@ssc.com. Answers that are copied to LG will be printed in the next issue in the Tips column.

Before asking a question, please check the Linux Gazette FAQ to see if it has been answered there.

 Tue, 01 Feb 2000 12:16:28 -0200
From: Clovis Sena <csena@itautec-philco.com.br>
Subject: help in printing numbered pages!


I usualy print a lot of documentation. One thing that I would like to make is that my print jobs gets the pages to be numbered. So at the bottom of the pages we could see "page 1/xx" , etc. I had looked a while for info in how to set this up, but could not find. The printtool just dont do it. Maybe i should to create a filter, but what commands must i use to make this heapppens???

A other thing that would be nice is that is we could also print the location of the document, or the url, if it be a web page, like /usr/doc/html/mydoc.html or http://www.linuxjournal.com/article/example.html. Could this be done???

Any help will be welcome. Thanks for reading this.

 Tue, 1 Feb 2000 16:37:07 +0200
From: Knobel Alex <alex@pet.ac.il>
Subject: samba problim

hi and thank's fore your Help :0) will my english is "so bad so forgive me". will I have Linux Box With Kernel 2.2.12-20 Red Hat Linux & I Have Install The Samba Frome The Same CD I Have Red The HOWTO Samba & I Try What IT But I Dis'nt Anderstand How The Windows Shod See The Linux Box Will Frome The Linux I Can See The Network & see The Share But the NT Dosn't See The Linux In The smb.conf I Write The Follow

workegroup = staff    " i have a group cald staff"
netbios name = samba 

 Tue, 01 Feb 2000 11:46:50 -0500
From: Stan Wilburn <stan.wilburn@rhtelco.com>
Subject: Modem problem with 5.2

I have recently setup Linux 5.2 on a PC at home. The setup went great with only one problem: I cannot get the modem to dial so that I can access the Internet. Looking through various websites on Linux, I found that if your modem is on com3 there is some additional setup that is required. Can you help me with this? I have mapped the com3 port to /dev/cua2 and by the manual that is all I thought I had to do. I also ran statserial on this port and I get the correct information here also. What could be wrong? I can hear the modem clicking like it is trying to dial, but it will never dial the number. Thanks.

 Tue, 01 Feb 2000 15:48:28 MST
From: Sipe <dksclan@hotmail.com>
Subject: Linux on IBM Aptiva S6H

I have an IBM Aptiva S6H (214) with an IBM MM75 Multimeda monitor. I cannot seem to get my X server (Xfree86 -- current version #.#.5) with mandrake 6.1. I have an onboard ATI Mach64 3D Rage Pro card as well as a voodoo2, which supports rather high res. I've set custom frequencies (horiz: 69khz vert: 120khz) and picked my card from the card database. Still, when i run x windows, it's saying monitor res not supported and no monitor found, specifically "fatal server error" "no monitor". If somebody could help me out i would REALLY appreciate it! If you need more information about my computer or versions, please email me (dksclan@hotmail.com). I am desparate for help, i've tried irc dalnet and efnet #linux, friends, and checked many forums.

 Wed, 2 Feb 2000 01:46:20 -0500
From: Anthony H. Downey, Jr. <adowney@logicalinfo.com>
Subject: IP Masquerade Connection Problems

I've been running Linux for a few years now, using mostly RedHat distributions. I'm currently running RedHat 6.1. Recently, I decided to connect my small office (4 workstation nodes and 2 servers) to the internet via IP Masquerading rather than having each workstation dial directly (as was done previously).

IP Masquerading works fine, save for one small problem that's turning into a real annoyance. I'm using PAP authentication with the ISP. Whenever I initiate a connection, the modem dials, waits until whatever timeout is specified, then hangs up without ever achieving a complete connection. The two modems handshake, but the login to the ISP is never successfully completed. Since I've specified for it to reconnect on a line drop, it immediately redials and then successfully connects and logs in on the second try.

This is 99.9% consistent, meaning that it nearly always requires two dial attempts to get a successful connection. On rare occaisons, it will connect on the first try, but this is apparently only after I've just downed the interface within the past few minutes. I don't have it configured for demand dial at this point -- I normally bring the link up and down manually via ifup ppp0 and ifdown ppp0. Eventually this will be set to demand dial once I'm confident of the configuration.

I suspected the ISP at first, but then I tried a Mandrake 6.5 distribution on the same equipment (with essentially the same config files), and it connects the first time every time. I'd much rather use RedHat 6.1, however, for various reasons. I've even tried a few different modems, both 56K and K56Flex, and the results are the same.

Does anyone have any ideas as to why this would be happening and how to correct it?


 Wed, 02 Feb 2000 11:15:32 -0500
From: John Sanabria <jo-sanab@uniandes.edu.co>
Subject: Tip & Tricks


I'm currently work with the domain .edu.co at Universidad de los Andes, Bogota, Colombia. I want to know how can do when the people enter the url, uniandes.edu.co, the browser go at www.uniandes.edu.co. eg. i can type the url linuxtoday.com, and my browser show me www.linuxtoday.com.

Where do i modify my dns entry in order to obtain this behavior?

Thanks in advance.

PS: Sorry for my poor english.

 Wed, 2 Feb 2000 17:41:31 -0500
From: Rob C <rchan@idirect.com>


I was wondering what you have to do to get your Diamond Supraexpress 56i modem recognized and configured under Linux. I also need to get a PPP connection setup on my linux system to access my internet. I am positive that it isn't a winmodem.

I am a really new newbie at this, so i'll need lotsa explanating here.


 Thu, 03 Feb 2000 21:26:00 +0100
From: Ivo Naninck <inaninck@linuxfan.com>
Subject: Question to be published.

Hello LG,

Can you please put this in your next issue?

Anyone who has a hint on how to get a Linux DHCP client to get a lease from a DHCP server over a Token Ring network? I have already tried a LOT, believe me. Things like dhcpcd, dhclient and pump all do not work. There is also VERY little response on this matter from several related news groups.

Best regards, Ivo Naninck.
Neckties strangle clear thinking.
-- Lin Yutang

 Thu, 03 Feb 2000 23:08:31 +0100
From: JA <lubiec@datacomm.ch>
Subject: WindowsNT vs. Linux

I've made a comparison running the same Fortran program compiled with GNU g77 compiler with identical options.

The results is unexpected: the program ran under WinNT4.0 20 sec, and under Linux/Slackware7.0 27 sec.


Jacek Arkuszewski, Switzerland

 Thu, 03 Feb 2000 22:34:56 -0500
From: BLOODICE <bloodice@ipass.net>
Subject: Linux & win98 internet connection sharing

im just wondering if it is possible to connect linux to the internet, over a network through a win98 machine using internet connection sharing?

if there is a way, can you tell me if i cant do it that way is there another way i can do it?

also...do you happen to know of any cable modem software(for linux) that will run RoadRunner modems

one more thing...are there any tutorials on my first question that i should look at?

 Mon, 26 Apr 1999 14:23:10 +0530
From: Sreelal T S <sree1980@md4.vsnl.net.in>

My opl3-sax 32-bit soundcard was not supported by redhat linux6.1.I tried configuring it using sndconfig.Please send your responses.My address is kgkris@rediffmail.com

 Fri, 4 Feb 2000 17:43:38 -0600
From: Jeffrey T. Ownby <jownby@ecsis.net>
Subject: 5250 terminal for AS400 connection

I am adding a Linux box to a network consisting of several Win9X and NT machines that use either IBM Client Access or Rumba to connect to our AS400. Is there a program similar to either one of these that can provide terminal emulation on Linux. Any info appreciated!


 Wed, 09 Feb 2000 09:18:14 +0100
From: Vipie - Your Leader <vipie@operamail.com>
Subject: Multiple video cards


I have a question, have you any idea where I could find info about running multiple video cards and monitors under linux. eg. 2 SVGA cards or a SVGA and a VGA card ... and how should one configure these ??

 Wed, 9 Feb 2000 10:37:33 +0200
From: Mahdy <mahdy@mail.pet.ac.il>
Subject: dos boot disk that can logon to linux

i know that my quistion is silly but i didn't find in the wep solution will i'm trying to make a boot disk fore dos that can see my linux box in my linux box i have install samba v2.0.5 will frome win 95/98/NT i can see the linux but frome dos i cant i need this thing to restore the Ghost files (image of disk) to the station until now i do this thing thru the NT server & in the client machien i run the NET.exe file to make this connection ? is there application fore dos that i can use and to be in one floppy disk 1.44 MB ?

Hijaze Mahdy

 Wed, 09 Feb 2000 12:42:27 +0000
From: thierry.lamant <thierry.lamant@free.fr>
Subject: Configuring Xfree for i810 chipset

I have successfully introduced Linux and XFree (now 3.3.5) in my company for the development of Aircraft Simulators on PC. I would like now to use it on my home computer, a Compaq Presario 5456 which include a i810 chipset. I can see that XFree 3.3.6 is supporting i810 mother board, but that does not work better than 640*480 when I try to install it (Win98 is running good at least in 1024*780). SuperProbe cannot detect the hardware.

Is there something special to do? Shall I wait for XFree 4?

Thanks in advance for any help.

Best Regards (and thousands thanks for the usefull Gazette)

 Tue, 8 Feb 2000 23:05:15 -0200
From: pedroanisio <pedroanisio@bol.com.br>
Subject: Clenning Lost+Found?

I having problem with my filesystem lately. And I have a lot o file in my lost+found, and I am having some problem to cleaning up those file which corrupted.

b---rwS-wt   1 30291    357       88, 118 Dec  8  2023 #586
b--sr-S--t   1 27968    27968    115, 109 Apr 29  2032 #592
br-xrwS-wt   1 14963    25715    108,  97 Apr 12  2031 #683
br-xrw----   1 29555    21622    115, 115 May 10  2031 #713
br-S--S--x   1 26483    14641    116,  97 Apr 12  1998 #732
br-xr-xrw-   1 10604    24864    101, 114 Feb 13  1996 #741564
c---r-----   1 8224     25632     32,  32 Jan 29  2029 #741565
br-sr-xrwx   1 29806    24864    116,  32 Oct 15  2021 #741567

I tried rm -rf but it didnīt work, it result in

rm: cannot unlink `file': Operation not permitted

what can I do? Thank You,

[When people have gotten weird permissions like that, it's often the sign of serious disk corruption. I would definitely back up any data you can right now just in case the drive fails in the near future. Is the drive otherwise working OK? I would be inclined to buy a new drive and install a fresh copy of Linux on it, and then later decide whether to trust this drive enough to continue using it. Hard drives and power supplies are the most failure-prone components of any PC. Fortunately, nowadays hard drives are cheap to replace.

You can run "file" on the files to see what types they are, and "less" to see if they have any contents worth saving. -Ed.]

 Thu, 10 Feb 2000 15:07:36 -0800
From: Chris Dumont <chrisd@ece.ubc.ca>
Subject: linuxconf

I've been trying to use linuxconf (ver 1.14 on a RH 6.0 install) and have now screwed it up in my computers at work and at home in the same way. When I'm ready to leave linuxconf it wants to "sync" the configuration with the system. Every time I run linuxconf now it says that it must execute "/etc/rc.d/rc5.d/S85gpm start". And then, even after it does so, it still says it's not in sync and it wants to do it again. I guess that it thinks it must start the mouse even though it's already running.

How do I fix this?

A possibly significant piece of information is that in both cases when I originally installed Red Hat I chose the wrong mouse driver and had to play around to find the right one.

 Fri, 11 Feb 2000 22:43:26 +0100
From: Daniel Lüscher <daniel.luescher@pop.dplanet.ch>
Subject: Linux-Mandrake 7.0

Hello! What about Linux-Mandrake 7.0? It would be worth an article or even an interview with the developers.

Greetz Pat

 Sat, 12 Feb 2000 14:14:40 +1000
From: Tony Smith <tony.smith@usa.net>
Subject: Help wanted etc.


This little problem has been sending me nuts for two days now. I sure hope someone in the LG community can help

I wonder if someone would mind helping me with a mystery that is causing me to pull my hair out......

I have been using a Linux server based on RedHat 5.2 for some time to connect to the Internet and provide masquerade for a bunch of Windows boxes on a private network behind it.

Today I decided to redo the server to incorporate a few more sophisticated things like DNS, DHCP and HTTP serving for a prototype intranet.

All went very well with one small hiccup. There seems to be an undocumented change in the behavior of ppp between RedHat 6.1 and 5.2.

Using 5.2 invoking "ifup ppp1" will result in the server making one and one only attempt to connect to the internet.

This is exactly what I want

Using 6.1 if the dialout attempt fails, it simply loops and tries again and again until it either connects or is stopped.

I don't want this.

I have compared all the relevant (I hope) scripts between 5.2 and 6.1 but I cannot find a difference that would account for the changed behavior.

I have the awful feeling I've missed something important (it's been a long day), could someone please tell me what it is?

 Sun, 13 Feb 2000 04:59:29 +0200
From: FreeDoM <free_dom34@hotmail.com>
Subject: ZOLTRIX modem

Hi My name is Ozgur; I use redhat Linux but I dont use modem I have 56K Zoltrix (Rockwell cheap set) modem Winmodem but this modem dont run under Linux could u help me? If u have file this problem pls send me!

Tnx for helping.

 Sun, 13 Feb 2000 22:01:33 -0600
From: Kim Updike <kupdike@met-net.com>
Subject: Inexpensive, powerful db's for Linux?

To develop a distributed database application that runs on Linux, what inexpensive, powerful databases might work best?

E-mailiing me at kupdike@met-net.com with any advice would be much appreciated. -Kim

 Sun, 13 Feb 2000 10:53:21 -0500
From: Art <mperry@pei.sympatico.ca>
Subject: Drivers

I have a question. Where can I download an update driver for a "Diamond Monster 3D" voodoo card? The present software I have is Version 1.08 and DOS 6. My OS is Win98 Second Addition 64Mg Ram and Celeron 300 with an I intel 740 video card. I thank you in advance for your reply. Art

 Tue, 15 Feb 2000 08:14:24 -0500
From: William Aycock <william.e.aycock@lmco.com>
Subject: Window Managers and Window App Development

  1. Do you have an automatic email when a new issue is available?
  2. Do you know which window manager will become the standard? It appears to me, from my limited exposure, that KDE and Gnome/Enlightenment are the front runners. Do you have an article on this issue?
  3. What are some good IDE's for window development and where can I get documentation for them?
[There's an lg-announce mailing list. See the Linux Gazette FAQ at http://www.linuxgazette.com/faq/index.html http://www.linuxgazette.com/faq/index.html

KDE and GNOME are graphical "environments" (that is, a set of custom applications, widgets and rules that all have a common "look and feel"). A window manager is just one aspect of this. In my opinion, KDE is currently "ahead". But I don't tell people, "Use KDE, it's #1." I use KDE at work, but only because it's the default, and I don't use 90% of its features. At home I use fvwm2.

Some people want to see Linux have a single standard desktop. However, I think most people are glad there's a choice, because different people want different things. Indeed, with some people running Linux for games (i.e., they need a 3D video card and fast drivers) and other people running it on 486s as servers, different people have very different software needs. KDE and GNOME tend to appeal to people who want a standard look and feel a la Windows and the Mac. But those who hack with the older programming tools are never going to give them up. As the geek joke goes, "Who needs a GUI when you've got Emacs?"

February's Linux Journal had an in-depth look at KDE and at GNOME. Both articles are on-line at http://www.linuxjournal.com/lj-issues/issue70-Ed.]

 Wed, 16 Feb 2000 20:45:06 +0100
From: Dennis Johansen <dennis.johansen@email.dk>
Subject: Quakeworld server as a deamon

I want to set my RedHat Linux 6.1 up as a QuakeWorld server on my lan. Iīts a k6-200 with 64 mb ram.

And it works fine when i start it, but how do i run it as a deamon ?

Please help.

Best Regards

 Fri, 18 Feb 2000 08:47:02 +0200
From: Halil Cem Tonguc 998027 <tonguccem@hotmail.com>

Where can I found a patch for PIII????

 Fri, 18 Feb 2000 23:46:14 -0800
From: wesley <wesley@digi-dim.com>
Subject: make virtuald

I am trying to compile virtuald using make virtuald here is the error I get "Makefile:14: *** missing separator. Stop. "

I did a cut and paste of the code from http://www.linuxdoc.org/HOWTO/Virtual-Services-HOWTO-3.html in the section 3.4 Source then used ftp to put it on the server in order to compile it.

what am I missing??

thanks for your time and help


 Sat, 19 Feb 2000 23:53:46 +0000
From: Ari Hyvölä <ari@hyvola.com>
Subject: pppd daemon dies

Hello, I am a beginner in Linux world and would like to test Linux ISDN ability. I have ASUSCOM 128 modem connected to RS-232 port. ISP, IP and DNS are correctly set up but kppp hangs up while logging onto network with the error message "pppd daemon died unexpectedly" and the log says "cannot open logfile". The modem tests run through. I have Corel Linux 2.2.12 and the Kernel should include neccessary isdn and ppp -options. Lock option has been turned off. I appreciate any help - from Corel pages support can not be found.

 Sun, 20 Feb 2000 14:19:25 +0100
From: Santiago Cepas <HALAMAD@teleline.es>
Subject: Memory undetected

Hello there.

I've got some problems with my RAM: Linux only detecs 64 M when I have 128. My specs are: SuSE Linux 6.3, kernel 2.2.13, runnin in a AMD k6-2 350 box. The weirdest thing is that the whole 128 M are in the same DIMM slot. The bios seems to detect 128 M, and also that other op. system which in don't want to name. Could anyone help me here?


[Linux cannot auto-detect memory above 64MB. You have to tell it explicitly how much memory you have at the boot prompt, or put
append = "mem8M"
in your /etc/lilo.conf file and re-run lilo (if you're using lilo; see the lilo documentation).

The problem is that the BIOS detects the extra memory but it doesn't tell Linux about it. It's a limitation in the PC BIOS design. I don't know how that other OS probes for memory.

If you ever reduce the amount of memory you have, remember to tell lilo first. Otherwise, the system will segfault at boot time when it tries to use memory that isn't there. You can always type "mem=64M" at the boot prompt to override what lilo thinks.

Information from the Linus himself about situation is in the BootPrompt HOWTO . -Ed.]

 Mon, 31 Jan 2000 22:33:26 +0000
From: T.J. Rowe <tjr@ida.net>
Subject: glibc compilation problem

Hello everyone,

I'm making glibc 2.1.2 from the source tarball for use in building a system from the ground up (to get rid of all those statically linked programs I've started with). Well, when compiling either 2.1.2 or 2.1.1, I get following error and the compilation stops:

common/db_appinit.c: In function `__db_appname':
common/db_appinit.c:479: fixed or forbidden register 0 (ax) was spilled
for class
common/db_appinit.c:479: This may be due to a compiler bug or to
impossible asm
common/db_appinit.c:479: statements or clauses.
common/db_appinit.c:479: This is the instruction:
(insn 902 901 903 (parallel[
            (set (reg:SI 2 %ecx)
                        (mem:BLK (reg:SI 5 %edi) 0)
                        (const_int 0 [0x0])
                        (const_int 1 [0x1])
                    ]  0))
            (clobber (reg:SI 5 %edi))
        ] ) 424 {strlensi+1} (insn_list 901 (nil))
    (expr_list:REG_UNUSED (reg:SI 5 %edi)
make[1]: *** [db_appinit.os] Error 1
make: *** [db2/others] Error 2

I have pgcc 2.95.2, which I believe fills the requirement for gcc. I'm clueless as to what else can be causing this. Any ideas?

btw, I come up with some other undefined function error when trying to compile glibc 2.0.7pre6, and I don't want to use the older glibc, anyway.

Someone has to know what causes these kinds of errors, right? :)

 Mon, 31 Jan 2000 22:40:13 +0000
From: T.J. Rowe <tjr@ida.net>
Subject: bash problem

I have an interesting problem with my bash prompt. The upper case K and T letters do not echo to the screen, and when I type them it beeps at me. Now, before jumping to conclusions, let me describe what I've done so far. This problem only occurs in bash and bash2, not in tcsh, zsh, csh, etc. I've recompiled and reinstalled bash several times from both the source tarballs and source rpms. I've replaced very thing terminal related that I can think of, such as gettydefs and libtermcap. I've looked at my keymaps repeatedly, and there doesn't seem to be a problem there--and again, it only happens in bash. It has to be something broken which I haven't replaced yet, but I'm not sure what is left. The K and T letters work fine in programs spawned in bash, it's just the prompt itself. This one has just about everyone I know confused. Hopefully someone out there can help or has heard of this odd problem. If anyone would like more details or has any information, please contact me.

Thanks, ~T.J. tjr@ida.net

 Wed, 23 Feb 2000 14:45:47 -0500
From: LabRDist <LabRDist@ufl.edu>
Subject: bootup disk?

i have a toshiba 415cs and i formatted the hard drive. I dont have the toshiba companion disk or did i make a boot disk before i formatted it. i need to find a way to get into the computer to activate the d: drive to install windows. I just get an error every time i start saying insert the boot disk. Any help would be appreciated.

 Wed, 23 Feb 2000 21:29:29 -0800 (PST)
From: napolean <novac_s@yahoo.com>
Subject: question about linux 5.2 deluxe

i installed linux and then it said it was completed, then i got a prompt saying

[bonethugs@localhost bonethugs]$ 
after entering the password and login name what do i do? and i have one more question can you have linux and windows 98 on one hard drive with out being partitioned in half please e-mail me back please thank you very much

 Thu, 24 Feb 2000 10:22:52 -0000
From: Ivica Glavocic <ivica.glavocic@post.hinet.hr>
Subject: unable to install


I don't know if this is the proper way to contact you, but this is the address I found searching through Internet for solution for my problem:

PC is PII233 (LX) with 128 MB DIMM SDRAM, 6.4 GB WD HDD, Diamond Speedstar 50 AGP (4MB) VGA, Genius LAN card, Philips 40x CD, ps/2 keyboard and mouse. On it I have installed NT Workstation 4.0 on first partition (4G) formatted as NTFS. NT is working fine.

Now, I wanted to put Linux RedHat 6.1 on second partition. First I checked HCL for my PC - OK. On Internet I found documents how to boot Linux using NT Loader and everything seemed to be fine until i started actual installation booting it from CD. It loaded X graphical display, gave me choice for language and keyboard, and then disk druid started. I could see my NTFS partition as HPFS but I knew this would happen since I red about it before. So out of unused ~2 GB I created swap (129M) and root (2G) partition and after i pressed next, error was displayed "error opening security file ..." and termination and kill signals stopped further installation.

Now, I know that this is not a fatal error (security..), but what is the problem then? I tryed to change partitioning (added /boot partition, many combinations) but nothing seem to work. There is no explanation WHY this happens, on wich module installation fails. Then I got new boot diskette from RedHat, tryed with it, but same thing happened. So I put some boot parameters like MEM8M and changed keyboard type, but still nothing.

Maybe installation log would help, but it is going fast on my screen and I can't read it, is there a way to save it to diskette since I can't put it on NTFS partition? Is this partition a problem somehow? Shouldn't be.

Please answer as soon as you can because it is really urgent for me to get this Linux going.

Thank you in advance

Ivica Glavocic

 Thu, 24 Feb 2000 23:52:17 +0100
From: jacek czerwinski <jacy@poczta.onet.pl>
Subject: users' information on my netware 4.11

Novell ver >= 5.x has LDAP gateway to his NDS. These are many of LDAP clients (API from Mozilla, OpenLDAP, netscape). caldera has made NDS fo Linux (3 user trial ? - i cant download it from my small city and test ) (www.caldera.com) Novell said that in march/april will release Opensourced API for NDS based on OpenLDAP (www.openldap.org) Maybe LDAP gateway for NDS (in trial wersion ?) is free for download from Novell ? Write after your success ;-)

 Thu, 3 Feb 2000 08:43:48 -0800
From: Linux Gazette <lg@ssc.com>
Subject: FAQs

The following questions received this month are answered in the Linux Gazette FAQ:

General Mail

 Sat, 5 Feb 2000 20:07:59 -0800 (PST)
From: Ron Bates <raretek@yahoo.com>
Subject: Linux in Grocery Stores...

Hey, I just wanted to tell you guys, I purchased the premiere issue of Maximum Linux magazine with a full install of Linux-Mandrake 6.0 at Pak N' Save in So. San Francisco. To think the day has come when you can purchase a copy of Linux at your local chain grocery store. It's a beautiful world.

 Sun, 6 Feb 2000 23:14:00 -0500
From: Pierre Abbat <phma@oltronics.net>
Subject: Gazette crashes Konqueror

I am trying to read the Gazette with kfm 1.167 and several pages crash it, including the Mailbag and 2Ē Tips. Can you help me figure out what's wrong? It's happened before.


 Fri, 11 Feb 2000 15:05:04 +0100
From: Richard Vanek (ETM <Richard.Vanek@etm.ericsson.se>
Subject: current issue


I would like to download always current issue of Linux Gazette to my Pilot. Do you have general link which always point on contents of current issue?

Richard then wrote again, clarifying his request:

The download is done by avantgo server which prepare a html pages for downloading to Palm Pilot. I would like to setup link where I can always find a new issue. AvantGO will look at it and when it's change I will get a new pages into pilot.

The reason why link to the current issue is simple, if I point to your main page in level 1 of html I will have all issues which is too much for a Palm Pilot memory.

[I added a symbolic link http://www.linuxgazette.com/current pointing to the current issue. I also made index.html in each issue point to the Table of Contents page.

Readers, please do not bookmark anything through the "current" link! The bookmark will go dead at the end of the month or point to the wrong article. Instead, use the actual issue directory (e.g., issue51. -Ed.]

 Fri, 18 Feb 2000 08:35:58 -0800
From: Linux Gazette <lg@ssc.com>
Subject: Mirror site in India

Sankar wrote:

I am located in India, and keenly interested in hosting a mirror site which would actually be in India. Can you please let me know what would be approximate size required in the server for this?

The WWW directories are approximately 84 MB. Each issue will add 2-3 MB.

The size of the FTP files can be found at http://www.linuxgazette.com/ftpfiles.txt The current size is 43 MB, plus 1-2 MB for each new issue.

 18 Feb 2000 10:16:01 -0800
From: Michael Grier <e1city@altavista.com>
Subject: WebGlimpse Blank Page Syndrome

It has been my experience that Netscape will not display a page if there is a missing closing </table> tag somewhere, especially if there are nested tables. Try appending an extra one at the end of the table.

[You are correct. However, fixing this requires delving into the internals of WebGlimpse and Glimpse, which we do not have the resources to do. It also appears that Netscape is throwing away the bottom of the page when a large result set is returned, and that's where the </TABLE> tag is going. -Ed.]

 Fri, 25 Feb 2000 10:46:34 -0500
From: Jeff Rose <whisper@iag.net>
Subject: Main LG Logo ...


Agreed, I am *not* any type of GIMP-guru [see _my_ horrible non-aliasing problematic logo] ... however, a suggestion:

The Linux Gazette Main Logo is, well, ugly!

Perhaps you could encourage the readership to submit their own logo creations for Linux Gazette and have fun while making an improvement at the same time?

Hope this sounds like a plan,


 ( >-    Jeff Rose - everyone's Linux User Group (eLUG)     -< )
 /~\    http://www.elug.org        mailto:jrose@elug.org     /~\
|  \)          *** Freelance Linux/IT Writer ***            (/  |
 |_|_                 eFAX: +1.630.604.4130                 _|_|
[The staff and readers of LG are divided over whether it's time for a new logo. I myself am undecided. But I can do this:

If you or any readers wish to submit artwork for the Gazette, I will put them in a "Linux Gazette Art" article so when we can all see them. They will then be available when I go looking for something to jazz up a page with.

This was how the "Penguin Reading the Gazette" image at right found a home on the LG FAQ page. We had the existing image from the days when Margie was the Editor of the Gazette. (She still retains the title "Ruler of the Gazette"--she refused to give me that title! :) I liked it, used it in one of my Not Linux columns, and then decided it would make a good image for the FAQ.

The LG logo is 600x256, and any new logo should probably be the same size. The Penguin Reading the Gazette is 161x160; most page decorations will want to be more or less that size. Page decorations are a lot more likely to be used in future Gazette issues than logos are, because there can be only one logo. All images should have a Linux Gazette theme in their content somehow.

With this in mind, send in some art! -Ed.]

 Fri, 25 Feb 2000 13:07:44 -0500
From: Jason Fink <jay_rf@exis.net>
Subject: Pundit Here, Pundit There, Pundits Everywhere

Pundit Here, Pundit There, Pundits Everywhere

Pundits. Had enough of that word yet? I know I have and I also know there are a few of these so-called experts whose teeth I would like knock out (I guess the web equivalent would be breaking their knuckles or something). In all honesty, since when did becoming an expert one area of technology suddenly make one an absolute know-it-all about all technology? This has suddenly become the new thing to be: an industry pundit, a technology pundit, or whatever. A pundit, by the definition I refer to, is an accomplished expert in a particular discipline. This e-world of ours has suddenly given anyone who has the time and tenacity to become a pundit the opportunity to do so. Those whom have been in the industry a long time have received that label, and rightfully so, for excelling in a particular field. All of a sudden, however, many of these pundits are breaking away from their disciplines and yammering about others. I would rather they did not.

The Neo Pundit Know It All

This is the group that really irritates me. They started out as people who knew a lot about something, and in some cases, they outright contributed to making something, setting a trend or engineering a brilliant new process. While these people should be (and have been) commended, after a period of time they suddenly become experts in other fields as well, but now they can forego validation. Why that is, I have no idea. One can relate it to actors/actresses or music stars who suddenly feel they should become involved with politics and that their ideas are right. While there is a difference of sorts, you can see the obvious parallel: I'm a somebody now so everything I say should be taken seriously.

Losing Readers

This sort of abuse of journalistic power needs to stop, someone needs to start putting an end to it. The reason it needs to stop is not just ethics, it really has more to do (in my opinion) with quality. If a person is particularly known for having insightful columns on a given subject, chances are, I will read them. The second they step into unknown territory and blunder, they lose credibility in my eyes. While I may be just one person, I highly doubt I am the only one who stops reading the material they write about because they blundered.

Misinforming Glassy Eyed Suits

Another point many administrators have brought to my attention has been the pointy-haired-boss syndrome. A Glassy-Eyed Suit (IS Department Head) reads a well-known, well-respected pundits column. It must true, right? Those who know no better cannot be protected by the sane. A pundit writing about something outside the sphere of their knowledge is in fact damaging the industry as a whole. Knuckleheads across the world will do a 180 based upon what some guy at some zine printed. Surely this is a good enough reason not to arbitrarily write about something.

I Did it for the Hits . . . Come on the Hits . . .

Word has it, if you secretly embed the word Linux on Coke cans, Coke sales will skyrocket. Zines across the globe are printing Linux this and Linux that, all for the sake of advertising dollars. That, in itself, is disgraceful. It is bad enough that there are so many 2-bit sites in general The fact that established journalists are using Linux to bring in the hits is repulsive.

Okay Wise Guy What About YOU?

So am I being hypocritical? In a sense, yes, because I really do not know much about Journalism, then again, I am not a pundit now am I? This trend has been going on for a long time now. It is my hope, that by seeing this, not only will you as a reader take the extra step to verify the information source, but perhaps those readers out there who are writers will think twice about their next article.

[The thing about Linux on coke cans reminded me of something somebody said at the Python conference. He said, a Linux Janitorial Service could go IPO just because it has the word "Linux" in it. Then the stockholders would be surprised to realize they were serious about the "Janitorial" part. -Ed.]

This page written and maintained by the Editor of the Linux Gazette. Copyright © 2000, gazette@ssc.com
Published in Issue 51 of Linux Gazette, March 2000
[ Table of Contents ] [ Front Page ] [ Linux Gazette FAQ ] [ Next ]